aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authoreug-vs <eugene@eug-vs.xyz>2023-08-31 11:30:46 +0300
committereug-vs <eugene@eug-vs.xyz>2023-08-31 11:30:46 +0300
commit4fab0d63413987974f5eb6fee59d2caf9494f789 (patch)
tree78a8bf81727a298aaad59527d5617c7f3b6b336b /Cargo.toml
parent80cee11b945c57de78b8eadad4da88c7145093f3 (diff)
downloadchessnost-4fab0d63413987974f5eb6fee59d2caf9494f789.tar.gz
chore: install smallvec
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 62a6499..ca8466d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,6 +8,11 @@ edition = "2021"
[dependencies]
num_enum = "0.5.7"
rand = "0.8.5"
+smallvec = "1.11.0"
+
+# Allow profiling with cargo flamegraph
+[profile.release]
+debug = true
[[bench]]
name = "perft"