summaryrefslogtreecommitdiff
path: root/media-libs/libspotify/libspotify-12.1.51.ebuild
diff options
context:
space:
mode:
authoreug-vs <eugene@eug-vs.xyz>2022-04-22 15:04:29 +0300
committereug-vs <eugene@eug-vs.xyz>2022-04-22 15:04:29 +0300
commit54cb832bb19dbd381bd2ed2aafab46b9f0398ffd (patch)
tree04b0b9c1ef38cd03b4965276bf23bc56129ed3d9 /media-libs/libspotify/libspotify-12.1.51.ebuild
parent8651953c96f6b0dc1c96c8ccb660410646c93e96 (diff)
downloadebuild-repository-54cb832bb19dbd381bd2ed2aafab46b9f0398ffd.tar.gz
feat: add libspotify ebuild
Diffstat (limited to 'media-libs/libspotify/libspotify-12.1.51.ebuild')
-rw-r--r--media-libs/libspotify/libspotify-12.1.51.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/libspotify/libspotify-12.1.51.ebuild b/media-libs/libspotify/libspotify-12.1.51.ebuild
new file mode 100644
index 0000000..9f58a72
--- /dev/null
+++ b/media-libs/libspotify/libspotify-12.1.51.ebuild
@@ -0,0 +1,27 @@
+EAPI=8
+
+HOMEPAGE="https://github.com/mopidy/libspotify-archive"
+
+SRC_URI="https://github.com/mopidy/libspotify-archive/raw/master/${P}-Linux-x86_64-release.tar.gz"
+
+S="${WORKDIR}/${P}-Linux-x86_64-release"
+
+SLOT="0"
+
+KEYWORDS="amd64"
+
+PATCHES=(
+ "${FILESDIR}/destdir.patch"
+)
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake install DESTDIR=${D}/usr LIB=lib64
+}
+
+src_uninstall() {
+ emake install DESTDIR=${D}/usr LIB=lib64
+}