summaryrefslogtreecommitdiff
path: root/dev-util/openring/openring-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/openring/openring-1.0.1.ebuild')
-rw-r--r--dev-util/openring/openring-1.0.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/openring/openring-1.0.1.ebuild b/dev-util/openring/openring-1.0.1.ebuild
new file mode 100644
index 0000000..d69d364
--- /dev/null
+++ b/dev-util/openring/openring-1.0.1.ebuild
@@ -0,0 +1,49 @@
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="A webring for static site generators"
+
+HOMEPAGE="https://git.sr.ht/~sircmpwn/openring"
+
+# TODO: this is deprecated. Host a dependency tarball instead
+EGO_SUM=(
+ "git.sr.ht/~sircmpwn/getopt v0.0.0-20190214165041-9a4f886f9fc7"
+ "git.sr.ht/~sircmpwn/getopt v0.0.0-20190214165041-9a4f886f9fc7/go.mod"
+ "git.sr.ht/~sircmpwn/getopt v0.0.0-20190621174457-292febf82fd0"
+ "git.sr.ht/~sircmpwn/getopt v0.0.0-20190621174457-292febf82fd0/go.mod"
+ "github.com/SlyMarbo/rss v1.0.1"
+ "github.com/SlyMarbo/rss v1.0.1/go.mod"
+ "github.com/axgle/mahonia v0.0.0-20180208002826-3358181d7394"
+ "github.com/axgle/mahonia v0.0.0-20180208002826-3358181d7394/go.mod"
+ "github.com/davecgh/go-spew v1.1.0/go.mod"
+ "github.com/mattn/go-runewidth v0.0.4"
+ "github.com/mattn/go-runewidth v0.0.4/go.mod"
+ "github.com/microcosm-cc/bluemonday v1.0.2"
+ "github.com/microcosm-cc/bluemonday v1.0.2/go.mod"
+ "github.com/pmezard/go-difflib v1.0.0/go.mod"
+ "github.com/stretchr/objx v0.1.0/go.mod"
+ "github.com/stretchr/testify v1.3.0/go.mod"
+ "golang.org/x/net v0.0.0-20181220203305-927f97764cc3"
+ "golang.org/x/net v0.0.0-20181220203305-927f97764cc3/go.mod"
+)
+
+go-module_set_globals
+
+SRC_URI="https://git.sr.ht/~sircmpwn/openring/archive/${PV}.tar.gz -> ${P}.tar.gz ${EGO_SUM_SRC_URI}"
+
+LICENSE="GPL"
+SLOT="0"
+KEYWORDS="amd64"
+
+BDEPEND=">=dev-lang/go-1.16"
+
+src_compile() {
+ ego build
+}
+
+src_install() {
+ dobin openring
+
+ default
+}