summaryrefslogtreecommitdiff
path: root/media-libs/libspotify/libspotify-12.1.51.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libspotify/libspotify-12.1.51.ebuild')
-rw-r--r--media-libs/libspotify/libspotify-12.1.51.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/media-libs/libspotify/libspotify-12.1.51.ebuild b/media-libs/libspotify/libspotify-12.1.51.ebuild
new file mode 100644
index 0000000..9f58a72
--- /dev/null
+++ b/media-libs/libspotify/libspotify-12.1.51.ebuild
@@ -0,0 +1,27 @@
+EAPI=8
+
+HOMEPAGE="https://github.com/mopidy/libspotify-archive"
+
+SRC_URI="https://github.com/mopidy/libspotify-archive/raw/master/${P}-Linux-x86_64-release.tar.gz"
+
+S="${WORKDIR}/${P}-Linux-x86_64-release"
+
+SLOT="0"
+
+KEYWORDS="amd64"
+
+PATCHES=(
+ "${FILESDIR}/destdir.patch"
+)
+
+src_compile() {
+ true
+}
+
+src_install() {
+ emake install DESTDIR=${D}/usr LIB=lib64
+}
+
+src_uninstall() {
+ emake install DESTDIR=${D}/usr LIB=lib64
+}